请选择 进入手机版 | 继续访问电脑版

华硕路由爱好者社区

 找回密码
 立即注册

手机号码,快捷登录

搜索
查看: 922|回复: 20

[求助] 使用GT-AC5300到目前为止的几个功能性问题(2.4g信号和iot)

[复制链接]

4

主题

28

帖子

143

积分

注册会员

Rank: 2

积分
143

RT-AC5300GT-AC5300

发表于 2019-8-2 23:39:54 | 显示全部楼层 |阅读模式
本帖最后由 luat 于 2019-9-15 14:40 编辑

9月15日更新:USB3.0干扰及速率底下问题
1、USB3.0干扰这个我知道,我之前小米路由器一代就被科普过了。
2、记得小米路由器hd(r3d)的时候也是像这样(当时主要是小爱音箱mini非常不稳定,后来路由器和部分iot设备更新了几个版本固件之后就很稳定了。所以开始的时候想到的是小米的iot设备兼容性出了问题。
3、路由器刚装的时候没有接任何usb设备,也是对2.4giot设备非常不友好。当时一直在掰扯iot设备,后来家里人说手机信号比换路由器之前还差一些,这才看到2.4g信号问题。
4我做测试插了usb3.0移动硬盘,不过硬盘是处于休眠状态下测试的(路由器设置了硬盘休眠,硬盘上有指示灯也是熄灭的)。
5、看到你的回帖说干扰问题我就做了几组对比实验(①插拔移动硬盘,②开关USB3.0,③静止或者传输数据时测2.4信号)。我就不贴图,直接说结论了。也是奇怪了,我今天无论怎么测试iot设备都没掉线,2.4g的信号基本上不像以前那种下降幅度。这是好事,但是我就没搞懂,路由器也没有升级固件,也没有改啥设置,就这么好了。所以我也不知道怎么怎么搞好的,排查一下近期家中无线设备及环境改动情况。也没找到思路。
6、排查第一次发现iot连接问题和现在,期间发生的环境变化:①中途发现有陌生设备连上路由,就改了wifi的密码;②换密码后家里两台海尔空调(2.4g设备)就没连到路由上了;③路由器放置,从书房到客厅(家里就100平,墙体偏薄。除了穿越三层剪力墙的厨房不稳定以外其他房间都可以连上。两种放置放法区别:路由器和终端的分布一个是半圆,一个是星状分布),高度从1米左右到40厘米的样子;可能影响到的因素就这么多了。
说说信号干扰的问题:
7、按道理说USB3.0在使用时,会在2.4G频段增加约20dB的噪声,于是我用有线电脑往挂在路由器上面硬盘传输文件的时候,对照看了2.4g的信号强度,基本稳定在-65dbm左右,速率是173m。这个时候上传速度比较稳定,是79m左右。对照了几组,发现开不开3.02.4信号强度和速率影响不大。(接口未做屏蔽,移动硬盘距离路由器大概70cm左右吧。)
8、路由2.4g为啥没影响我也不知道,不过我在路由器里面没有找到类似“降低usb3.0干扰”这个选项,不知道是不是这款路由器固件没有这个选项,或者硬件模块上面做了屏蔽,这个就不得而知了。
9、再就是之前测试的时候信号是可以正常的,改几个2.4g设置,重新应用设置,信号强度就回来了。所以感觉不像是USB3.0的锅。
再就是速率问题:
之前说速率问题锅找到了,是因为小米mix3手机的问题,好像这手机2.4g的速率最高也就173m。下次tpwdn8280降价了,整一个看看速率。不过现在iot设备已经没有掉线了,也就不用再折腾了。
最后,说实在的我就怕狗东上买到坏的,最开始担心是不是天线那么多,我没有接好,或者是天线坏掉一根什么的。总之,等我买了wdn8280测了之后才能安心吧,现在iot稳定了算是放心一半。




8月21日更新:

这段时间一直在使用3.0.0.4.384_45717固件,老问题解决了一点,但是有出现新问题。
①使用旧版固件之后,2.4g信号比新版本明显好一点,但是速度就惨不忍睹了,反正路由工作最大速率没过200m。刚才我又刷到3.0.0.4.384_70116,发现同样的测试地点2.4g直接掉没了,非得挨着路由器才有信号。但是很诡异的是访客wifi信号还行。
②旧版本的固件出了一个新问题,就是在小米电视3上面使用kodi,用smb协议。播放视频的时候出现视频中断的情况。目前没想明白是为啥。看到有帖子说华硕的smb还是十几年前的1.0的协议,现在主流应该是3.0的协议。不知道是不是这块兼容性有问题。
③看到很多人说梅林固件,我就吐槽一下,gt5300就这么坑爹,一堆问题还用不上梅林固件。这路由器我挺中意的,但是这几个问题头疼。
④关于2.4g的信号问题。我做了多组对比测试,有个结论大家试试看。重启之后信号很大概率出问题,这个时候把msc改一下,然后再改回来。信号就能莫名其妙的恢复,iot设备都在线,至于路由2.4的工作速率还是很慢。
⑤我想问问我这种情况是不是应该走一波售后换个机器了?各位怎么说?


8月6日更新信号测试在5楼:
传送门

测试部分数据截图在五楼,上面有传送门。我看着数据猜测了一下,下面是结论。

结论:
①前期测试的结论之前已经说过了,感觉是软件问题。因为只要不重启路由情况下,改变几个无线网络设置,重新应用就能好(iot设备都连上了,信号也正常了,不成对数下降了)。比如说MSC调到7或者9,只工作在N网模式(或者是兼容模式)下,区域调到澳大利亚等等。
②换到旧版固件3.0.0.4.384_45717之后也做了测试。可能因为摆放问题,重启数次之后,IOT设备基本都在线。但是还是有下列问题:
③信号衰减还是存在2.4g没有5g信号好的情况,但是差的不多就20%左右,不会像之前那样对数下降到完全搜索不到wifi。可是理论上2.4g的信号应该略好于5g的吧。
④再就是速率问题。测试显示2.4g在-66dbm信号强度下到手机只有10m下行速度,延时方面到路由器21ms,到dns有37ms。但是5g和5g2基本上速率都能到200m,且延时都在12ms左右,5g2延时能到4ms左右(这里吹爆华硕5g2)。
⑤然后再就是我坐在路由器跟前测试的一组数据,5g和5g2挺好的,速度正常,延时都降到4ms以下了。但是2.4g这个就诡异了延时是48ms和72ms,于是跑回之前测试点测试再也没有测到21ms和37ms。这里怀疑是不是周围2.4g信号干扰的原因产生这么大浮动。
⑥刚才又开着软件看了一下实时的速率(这里就不上图了)。在旧版固件下,测试点处2.4g的信号-68dbm,速率在86Mbps到115Mbps之间浮动;然后走进路由器,测试点处2.4g的信号-25dbm,速率在173Mbps处固定了。
⑦总结一句话,我刷了旧版固件感觉IOT设备基本没掉线了,但是这个速率和信号还是有点问题。是硬件问题么?要换个新的看看么?感觉换新的好麻烦。




==========================================================分割线=========================================================

原贴:

多年没怎么发帖了,不会排版见谅了。

2019年618狗东购入,到现在一个多月了。到论坛差不多也一个多月了吧。进入正题:

一、使用环境
1、互联网是027电信200M,光猫未破解,电信也不给开桥接。
2、路由离地70厘米左右,放置在客厅,位于房间中间。
3、网线5e和6类,所有有线路都是工作在千兆。
4、家中算上手机和各种小米IOT设备,常用的设备连接有15个,多的时候会连接20多个。
5、电脑Win10 x64,谷歌浏览器。
6、WiFi干扰还好。

二、路由设置
1、三个频段SSID都不一样,访客只开了1组(双频段,未开5G2,SSID相同)。隐藏了5G的SSID。
2、为了兼容性2.4G的mcs调到了7,5G的两个都是默认。
3、无线网络的漫游助手全关了。
4、AiProtection打开了,用的默认设置没改啥。
5、QoS点开了,选的游戏模式。
6、Wi-Fi Radar默认没点开。
7、VPN没使用。
8、只开了SMB,关了UPnP媒体服务器。
9、安装了下载大师,挂了一个希捷4T硬盘,NTFS格式,开的USB3.0,及打开硬盘自动休眠。
10、路由器固件版本:3.0.0.4.384_70116
11、其他设置都是默认的没动。

三、问题
1、刚入手的时候,全部设置均为默认设置。只设置了SSID,发现家中小米的IOT设备大面积掉线。
2、就像网上说的一样,访问过路由器挂载的硬盘之后,路由的内存就99%,无论负载高低,无论硬盘是否处于休眠。只要不重启,设备内存就会永远满载。
3、设备内存满载的时候,路由器管理页面出现好几个异常。
     ①系统管理==》固件升级  这个界面出现排版错误。
     ②Dash Board界面的“网络ping”和“ping偏差”没有任何数值图表显示。
     ③下载大师登录界面正常,但是登录后完全无法正常显示。
     ④重启功能失效,需要手动重启设备。

四、重点说一下IOT掉线的问题

1、家里IOT设备主要是使用2.4G,少数几个是支持5G的。
2、设备大面积掉线一般是路由重启之后,5米外的设备怎么都连不上。使用小米MIX3手机检查2.4G的WiFi信号,路由器跟前满格,无障碍支线距离5米的时候信号就只有一半不到了,而且时强时弱。基本上1层非剪力墙都无法穿透。
3、但是出现IOT无法连线的时候,2.4G信号有问题,5G信号稳如狗。两面墙直线距离8米左右,2.4G直接没信号,5G信号能有80%左右。
4、开始怀疑是兼容性问题,把2.4G的MCS调整到7,然后重新应用无线网络(不是重启设备)。竟然神奇的好了,同等距离情况下,信号2.4G略比5G好一点。路由器基本正常运作。
5、当时以为是路由器的兼容性问题。后来无意中重启一次路由器,在上面的配置下2.4G的问题又来了。路由器重启后2.4G信号开始各种飘,信号离开5米外成对数下降。
6、寻思着设置MCS7没效果。于是又尝试几种方法(之前几个说路由掉线的回帖里面写过当时的尝试方法)。都是在设置之后重新应用2.4G无线网(非重启路由)后修复的。

五、关于2.4G的IOT设备掉线的思考
1、我拿着手机在家里转悠,掉线的IOT设备和手机都找不到2.4G网络。感觉就是信号问题。
2、而且路由面前信号满格,5米无障碍信号直接掉一大半,这个太诡异,不好说是软件还是硬件问题。(MIX3手机简单目测)
3、路由器重新应用无线网络的时候(目前2.4G的一直MCS7),信号恢复正常,IOT设备都稳定连接。(感觉和设置没什么关系,关键在于要重新应用一次无线网。)这个应该是软件问题吧?
4、我能想到的就是软件设置应用到物理层面出了问题?天线没坏了几个?(大家有什么方法测试天线的通路情况么?)对应天线不匹配?
5、感觉还是固件的原因吧,我再观望一段时间,目前iot设备都在线。

六、几个小建议
1、关于内存满载的情况。能增加一个内存释放功能到固件里么,或者把内存管理智能化?能智能化最好,就是又得一笔固件开发了。
2、路由设备有空余运算能力的话,能做到状态自检么,关于信号啊,天线啊这些硬件层面。配合手机APP应该是完全可以实现的吧。
3、现在IOT热潮,能针对IOT进行优化一波,光支持亚马逊的也太少了点,照顾一下国内玩家。
4、2.4G那个问题我看有很多玩家都反应了,你们自己也测测,我有空拿软件测个详细的再贴上来。
5、今天发现路由器满载不能重启的时候,除了DLNA偶尔到不到设备,SMB直接挂掉。普通上网功能完全不受影响。这个厉害了,出了故障我都没感觉,这块真是稳如狗。

本人不是学计算机的,就是个外码,说的不对的,还望指点

0

主题

7

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-8-5 04:48:45 | 显示全部楼层
我固件是3.0.0.4.384_45717没遇到你说的问题呢?

268

主题

2452

帖子

5952

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
5952
发表于 2019-8-5 09:26:47 | 显示全部楼层
如楼上所说,建议变更一下FW版本试试看

4

主题

28

帖子

143

积分

注册会员

Rank: 2

积分
143

RT-AC5300GT-AC5300

 楼主| 发表于 2019-8-6 12:24:22 | 显示全部楼层
涵哥 发表于 2019-8-5 09:26
如楼上所说,建议变更一下FW版本试试看

好的,谢谢。我刷上个版本试试看。

4

主题

28

帖子

143

积分

注册会员

Rank: 2

积分
143

RT-AC5300GT-AC5300

 楼主| 发表于 2019-8-6 16:15:25 | 显示全部楼层
之前做的几组WIFI测试如下:
因为近期注册不知道啥网站被拖库(也可能是前期),收到了勒索邮件,所以SSID打了码,不过做了标注的。见谅

一、前期测试
测试环境:路由器离地1米多,测试点基本无障碍,小米MIX3手机,直线距离8米左右,固件为官方新版3.0.0.4.384_70116,设置改动了mcs7,路由器正常使用后重启出现信号问题测试。
==============================================分割线===============================================
①手机WIFI列表截图

②手持测试2.4g信号


③周边WIFI干扰情况2.4g


④测试2.4G信号
      

⑤手持测试5g信号


⑥测试5G信号


⑦几个小时后的手机wifi列表截图


二、旧版固件测试
测试环境有些许改变:无线网络设置全部是默认设置(2.4g的MCS11),路由器离地50厘米左右,直线距离7米左右,沿途一个木门,半面非剪力墙。刷了旧版固件之后,重置并重启了路由器。

①旧固件2.4g信号测试


②旧固件5g和5G2的信号测试
   

③坐路由器旁边测试三组信号

      

三、结论
① 前期测试的结论之前已经说过了,感觉是软件问题。因为只要不重启路由情况下,改变几个无线网络设置,重新应用就能好(IOT设备都连上了,信号也正常了,不成对数下降了)。比如说MSC调到7或者9,只工作在N网模式(或者是兼容模式)下,区域调到澳大利亚等等。
② 换到旧版固件3.0.0.4.384_45717之后也做了测试。可能因为摆放问题,重启数次之后,IOT设备基本都在线。但是还是有下列问题:
③ 信号衰减还是存在2.4g没有5g信号好的情况,但是差的不多就20%左右,不会像之前那样对数下降到完全搜索不到wifi。可是理论上2.4g的信号应该略好于5g的吧。
④ 再就是速率问题。测试显示2.4g在-66dbm信号强度下到手机只有10m下行速度,延时方面到路由器21ms,到dns有37ms。但是5g和5g2基本上速率都能到200m,且延时都在12ms左右,5g2延时能到4ms左右(这里吹爆华硕5g2)。
⑤ 然后再就是我坐在路由器跟前测试的一组数据,5g和5g2挺好的,速度正常,延时都降到4ms以下了。但是2.4g这个就诡异了延时是48ms和72ms,于是跑回之前测试点测试再也没有测到21ms和37ms。这里怀疑是不是周围2.4g信号干扰的原因产生这么大浮动。
⑥ 刚才又开着软件看了一下实时的速率(这里就不上图了)。在旧版固件下,测试点处2.4g的信号-68dbm,速率在86Mbps到115Mbps之间浮动;然后走进路由器,测试点处2.4g的信号-25dbm,速率在173Mbps处固定了。
⑦ 总结一句话,我刷了旧版固件感觉IOT设备基本没掉线了,但是这个速率和信号还是有点问题。是硬件问题么?要换个新的看看么?感觉换新的好麻烦。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x

7

主题

109

帖子

327

积分

中级会员

Rank: 3Rank: 3

积分
327

RT-AC5300RT-AC86U

发表于 2019-8-6 21:01:47 | 显示全部楼层
2.4G确实有问题,我的RT-AC86U跟你一样,IOT设备会莫名其妙的掉线。我也反馈过了,不知道下个固件会不会修复

4

主题

28

帖子

143

积分

注册会员

Rank: 2

积分
143

RT-AC5300GT-AC5300

 楼主| 发表于 2019-8-6 21:44:16 | 显示全部楼层
全池泼洒 发表于 2019-8-6 21:01
2.4G确实有问题,我的RT-AC86U跟你一样,IOT设备会莫名其妙的掉线。我也反馈过了,不知道下个固件会不会修复 ...

你换新了么?我看有一些网友换了还有的直接退的。
也不知道是不是因为狗东买的这个本来就有问题。

下次更新如果还这样,我就换个新的看看。

28

主题

178

帖子

533

积分

高级会员

Rank: 4

积分
533
发表于 2019-8-7 19:41:17 | 显示全部楼层
我也是,某一个IOT设备会连接但没有网络。2.4G的IOT设备

7

主题

109

帖子

327

积分

中级会员

Rank: 3Rank: 3

积分
327

RT-AC5300RT-AC86U

发表于 2019-8-7 20:40:55 | 显示全部楼层
本帖最后由 全池泼洒 于 2019-8-7 20:42 编辑
luat 发表于 2019-8-6 21:44
你换新了么?我看有一些网友换了还有的直接退的。
也不知道是不是因为狗东买的这个本来就有问题。

没换新,我把固件降级到18年12月份的版本了,按你上面说的把这个msc改成7,测试几天试试

4

主题

28

帖子

143

积分

注册会员

Rank: 2

积分
143

RT-AC5300GT-AC5300

 楼主| 发表于 2019-8-21 20:38:13 | 显示全部楼层
涵哥 发表于 2019-8-5 09:26
如楼上所说,建议变更一下FW版本试试看

涵哥,我做了几组对比测试。也换了旧版本的fw,还是觉得2.4的信号很诡异。调整一下msc再调回来能解决强度问题,但是速率还是不对。详细情况我更新在上面的帖子前面部分了。
这种情况我是不是该换个新的看看了?
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|华硕路由爱好者社区 ( 苏ICP备16010857号-1 )苏公网安备 32050502000499号

GMT+8, 2019-10-22 07:04 , Processed in 0.037971 second(s), 23 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表